четверг, 20 декабря 2012 г.

cisco nat и маршруты


Мои первые шаги по освоению оборудования cisco
Настроим внутренний интерфейс
router#conf t
router(config)# interface fastethernet 0/0 - входим в конфигурирование нужного нам порта;
router(config-if)#no shutdown
router(config-if)#ip address 192.168.10.1 255.255.255.0 -присваиваем IP-адрес;
router(config-if)#ip nat inside – указываем, что  интерфейс используется для NAT(внутренний);
router(config-if)#exit

Если внутренних интерфейсов нужно несколько проделываем тоже самое и для них.
Также можно создать sub-интерфейс:
router(config)#int fastethernet 0/0.3 – создаем sub-интерфейс;
router(config-subif)#encapsulation dot1Q 3
router(config-subif)#ip address 192.168.11.1 255.255.255.0
router(config-subif)#ip nat inside
router(config-subif)#exit

Настроим внешний интерфейс
router(config)# interface fastethernet 0/1
router(config-if)#ip address 20.10.20.1 255.255.255.252 – присваиваем IP-адрес смотрящем в сторону провайдера;
router(config-if)#no shutdown
router(config-if)#ip nat outside – указываем, что  интерфейс используется как наружный для NAT;
router(config-if)#exit

Настраиваем NAT
routerconfig)#ip access-list extended NAsh_NAT – создаем список доступа для NAT;
router(config-ext-nacl)#permit ip 192.168.10.0 0.0.0.255 any -указываем  сети попадающие под NAT;
router(config-ext-nacl)#permit ip 192.168.11.0 0.0.0.255 any
router(config-ext-nacl)#exit
router(config)#ip nat inside source list For_NAT interface fastethernet 0/1 overload – активируем NAT;

Настраиваем маршрут по умолчанию(20.10.20.2 -адрес маршрутизатора провайдера)
Center_Router(config)#ip route 0.0.0.0 0.0.0.0 20.10.20.2 – маршрут по умолчанию;













vlan cisco


Пишу для себя, что бы не забыть так ка с ciscами сталкиваюсь редко  и знаний нет по этой теме.Делал на тестовом cisco 2691(ipbase)

router#vlan database -для создания vlan-нов;
router(vlan)#vlan 20 name buhi -создаем vlan-ны;
router(vlan)#vlan 30 name boss
router(vlan)#exit
router#conf t
router(config)# interface fa0/1 - входим в конфигурированние нужного нам порта;
router(config-if)#switchport mode access -устанавливаем режим access;
router(config-if)#switchport access vlan 20 -указываем какому vlan принадлежит этот порт;
router(config-if)#exit
router(config)# interface fa0/2
router(config-if)#switchport mode access 
router(config-if)#switchport access vlan 30
router(config-if)#exit
router(config)# interface fa0/0 
router(config-if)#switchport mode trunk -устанавливаем режим работы trunk;
router(config-if)#switchport trunk encapsulation dot1q – указываем инкапсуляцию;
router(config-if)#switchport trunk allowed vlan add 20-30 - указываем какие vlan будет пропускать данный порт(можно all);
router(config-if)#exit

Для коммутаторов наверное будет немного по другому выглядеть процесс создания vlan

Switch(config)#vlan 20 – создаем vlan;
Switch(config-vlan)#name buhi – задаем имя;
Switch(config-vlan)#exit

Если интерфейсов много 

router(config)#interface range fa 0/5 – 9 – задаем группу интерфейсов;
router(config-if)#switchport mode access 
router(config-if)#switchport access vlan 30
router(config-if)#exit







вторник, 21 августа 2012 г.

Настройка Cisco 877 adsl ростелеком

Зададим имя хоста:
Router(config)# hostname Cisco
Cisco(config)#
Отключаем управление через SDM CDP
Cisco(config)# no ip http server
Cisco(config)# no ip http secure-server
Cisco(config)#no cdp run

Все четыре порта  lan по умолчанию принадлежат VLAN1.
Настроим внутренний интерфейс:
Cisco(config)#interface vlan1
Cisco(config-if)#ip address 192.168.1.1 255.255.255.0
Cisco(config-if)#ip nat inside
Cisco(config-if)#no shutdown
Cisco(config-if)#exit

Cisco(config)#no ip domain lookup
Cisco(config)#ip name-server 212.12.0.2
Cisco(config)#ip name-server 8.8.8.8
Настроим   интерфейс atm, задим нужные параметры pvc и укажем тип инкапсуляции


Cisco(config)#interface atm0
Cisco(config-if)#no ip address
Cisco(config-if)#logging event atm pvc state
Cisco(config-if)#pvc 0/35
Cisco(config-if)##no shutdown 
Cisco(config-if-atm-vc)#encapsulation aal5snap
Cisco(config-if-atm-vc)#pppoe-client dial-pool-number 1
Cisco(config-if-atm-vc)#exit

Настроим виртуальный интерфейс Dialer0,  ip получаем по DHCP от провайдера (ip address negotiated), включаем NAT, указываем размер mtu, тип инкапсуляции (ppp), авторизации (ppp authentication pap callin), задаем параметры авторизации - логин и пароль
Cisco(config-if)#interface Dialer0
Cisco(config-if)#ip address negotiated
Cisco(config-if)#ip nat outside
Cisco(config-if)#ip mtu 1492
Cisco(config-if)#encapsulation ppp
Cisco(config-if)#dialer pool 1
Cisco(config-if)#ppp authentication pap callin
Cisco(config-if)#ppp chap hostname xxxx

Cisco(config-if)#ppp chap password xxxx

Cisco(config-if)#ip tcp adjust-mss 1452
Cisco(config-if)#exit

Назначаем маршрут по умолчанию.
Cisco(config)#ip route 0.0.0.0 0.0.0.0 Dialer0

Настраиваем NAT

Cisco(config)#ip nat inside source list 100 interface Dialer0 overload
Cisco(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255
Пробросим порт на внутреннюю машину
Cisco(config)#ip nat inside source static tcp 192.168.1.50 143 interface Dialer0 143
Дальнейшие настройки безопасности на своё усмотрение(no ip redirects, no ip unreachables, no ip proxy-arp и тд)



пятница, 17 августа 2012 г.

Asterisk перевод звонка

Для перевода звонка другому абоненту в параметрах Dial нужно добавит Tt 
exten =>500,1,Dial(SIP/202,,tT)
Перевод звонка происходит при нажатии #XXX#.

Подключение cisco spa3102 к Asterisk

Подключаемся к шлюзу используя порт lan(Ethernet) и ip 192.168.0.1, сразу нажимаем Admin login и Advanced. Как роутер использовать сей дквайс не рекомендую, но при этом для дальнейшего использования должен использоваться порт WAN. По этому, делаем соответствующие настройки wan порта (применимые к вашим реалиям), разрешаем вебдоступ на внешнем интерфейсе, устанавливаем пароль администрирования,сохраняем применяем иперемещае кабель в порт wan. Дальнейшие манипуляции с устройством будем производить используя внешний интерфейс и адрес который вы ему присвоили.




Подключаем аналоговый телефон и городскую линию к соответствующим портам шлюза.
Далее перейдем к настройке  порта FXS(телефон), называется Line1. Прописываем данные сервера Asterisk и параметры аутентификации.(если хотим использовать здесь свой диалплан кнопка его активации находится внизу страницы а описаний параметров полно на просторах интернета).


Соответствующие настройки делаем в sip.conf и extensions.conf yf Asterisk(не забываем применить изменения).



Звонки должны уже работать.
Теперь приступим к подключению городской линии(FXO) к серверу Asterisk.
На вкладке PTSN Line заполняем параметры для подключения к серверу. На вкладке
PSTN Ring Thru Line 1делаем No, чтобы при входящем звонке звонок на линию 1 не проходил, мы будем управлять этим из Asterisk.Строка Dial Plan2: (S0<:405)  -означает что все входящие вызовы будут адресованы как входящие с SIP/405 в Asterisk(не забываем активировать это в строке PSTN Caller Default DP: 2 ). Для нормального определения Diconnect тона городской АТС
делаем настройки в строке Disconnect Tone. Если будут проблемы с определение линии можно поиграться с напряжением линии Line-In-Use Voltage:.





После этого производим изменения кофигов Asterisk. В этом примитивном примере на городскую линию буде выходить через 9, а входящие переадресовываются на SIP/400 .








Подключение cisco spa303 к Asterisk

Примитивный пример подключения cisco SPA303 к Asterisk:
Запускаем вебинтерфейс телефона в браузере, нажимаем Admin login и приступаем к настройке сетевого подключения.

После чего переходим к настройкам подключения к серверу Asterisk(незабываем установить пароль на подключение к вебморде телефона).

Далее пропишем телефон в sip.cof и настроим диалплан в extensions.conf




Делаем в cli sip relaod и dialplan reload. 
Все, проверяем проходят ли звонки и приступаем тонкой настройке.

вторник, 31 июля 2012 г.

Настройка audiocodes mp-124 Asterisk

Столкнулся с задачей сопряжения audiocodes mp-124 24FXS и Asterisk. Знаний в этом направлении практически нет, настраивал методом научного тыка, а пишу всё это для себя чтобы не забыть.
Для начала настроим audiocodes, по названию вкладок назначение должно быть понятно(настраивал два первых порта с номерами 300 и 301):








Далее примитивные extensions.conf и sip.conf только для того чтобы понять как это работает:


понедельник, 18 июня 2012 г.

Установка сервера терминалов windows server 2008 r2

На предварительно установленном и настроенном сервере начнем добавление ролей службы терминалов.
Добавим нужные службы, "пробежимся" по мастеру.



После окончания установки, настраиваем лицензирование терминальных пользователей(активируем сервер лицензирования и лицензии), добавляем нужных пользователей в группу пользователей удалённого рабочего стола  и приступаем к работе.





Более гибкие настройки сервера терминалов производим через параметры групповой политики:



 По желанию можно добавить роль веб доступа к службам терминалов:

 Для добавление приложений RemoteApp, создания rdp файла или пакета установщика зайдем в диспетчер удалённых приложений RemoteApp служб терминалов:


 Зайдя на ip-сервера\ts\ мы увидим следующую картину (при условии разрешения веб публикации приложения):
Если нам нужно подключаться к серверу терминалов используя собственный сертификат мы можем его приобрести, либо создать самостоятельно: